Social Groups problem


Well-Known Member
I know this issue has been brought up before, but I (at least) am still having issues with changing pages in the Social Groups section.

From the main page, the two links for "View All Groups" brings you back to the main page. I know it is not, but it "looks" like a page refresh.

The link for "View All Categories" does work, and the individual category links work, but when viewing the groups within a certain category, and you click to advance a page (both through the number and the >) it brings you back to the main Social Groups page with the following address:

whereas the main Social Group page when accessed from the "Community" tab yields this address:

I have tried several times lately and get the same result. Figured I would let the powers that be know something was out of whack.
I think the new update addresses that. Hopefully I can get it resolved in the next 24.
Just a quick thought on something I missed from the first post. It will also kick you back to the main page when you try and search for a group. You can get to the search funtion just fine, but when you actually try to search, it kicks you back to the main page.
Might be something with the SEO feature, which is what I'm researching. I appreciate your patience.