Issues with Sheppard Air


Honorary Member
I tried opening up Flight Test 5 for the FOI and got a message that I need to renew my password. I tried calling Sheppard Air but it doesn't ring, I only get a bunch of beeps like the number has been disconnected. Anyone else having issues?


Unapologetically American
Hmmm. I have had problems getting someone to answer the phone before but not an issue with the number. Maybe they are busy. dunno! I would just email them an request a new UN and PW. I think the email is sheppardair @ I put spaces in the email addy so retype it into your email not copy and paste.

It did take about 12 hours to hear back through email. If you can't wait just wait a while and try calling again.


Well-Known Member
Same here, every time I have called they have always called back within an hour or two.


Honorary Member
Voicemail isn't an option as it doesn't even ring, just beeps like a phone that's off the hook. I'll try again tomorrow.


Gold Member
Must be something in the phone system. I just called them to get a price on the FEX test again, and they answered on the second ring.